RVAmerica.com Forums
 
RVAmerica ForumsRVAmerica ForumsBulletin BoardBulletin BoardGeneralGeneralHeater Fan wonHeater Fan won't run
Previous Previous
 
Next Next
New Post
 10/31/2012 1:29 PM
 

My dash heater fan won't run. I've checked the fuse and exchanged the relay. It's a '99 HR Endeavor on a Freightliner XC chassis.

Any ideas?

Bob K from PA


Bob and Gwen K from PA '99 Endeavor 37WDS4 2009 Ford Tarus or boat Four cats
New Post
 10/31/2012 2:01 PM
 
Bob - While it's possible the fan is bad, I'd start with the fan switch. Connect a voltmeter, or test light, to the power wire that feeds the switch and the other lead to ground. That'll show if the switch is getting power. Next, transfer the lead to the output wire or wires (low if switch is on low, etc.). That'll tell you if the switch is passing power to the fan. If power is going to the switch, but not coming out, replace the switch. Good luck - Dave
New Post
 11/1/2012 8:24 AM
 

"Or".....check to make sure you have a nice clean ground connection.


Neil
New Post
 11/14/2012 10:06 PM
 

Thanks for the replies. I haven't got back to the heater fan yet. DW wants the bathroom in our stick house painted. I'm trying to put it off 'till after Thanksgiving but I seem to be losing that battle.

Bob K from PA


Bob and Gwen K from PA '99 Endeavor 37WDS4 2009 Ford Tarus or boat Four cats
Previous Previous
 
Next Next
RVAmerica ForumsRVAmerica ForumsBulletin BoardBulletin BoardGeneralGeneralHeater Fan wonHeater Fan won't run

Horizon Block
Progressive Insurance