RVAmerica.com Forums
 
RVAmerica ForumsRVAmerica ForumsBulletin BoardBulletin BoardGeneralGeneralAtwood G6A 8E intermittent Ignition problemAtwood G6A 8E intermittent Ignition problem
Previous Previous
 
Next Next
New Post
 8/4/2013 5:09 PM
 
 Modified By Dan  on 8/4/2013 4:10:21 PM

I have had intermittent ignition problems with my Atwood water heater ever since I purchased my new motorhome in 2006. I followed all trouble shooting instructions to the letter. I finally think I found the root cause. There is a flame divertor at for the main burner. In the troubleshooting guide, it says it is a "dime-shaped" divertor. I assume that the guide should have read a "dime-sized" divertor. Well on my electronic ignition water heater the divertor was about the diameter of a pencil eraser, but I never gave it a second thought -- until I had a used burner in my hands. The divertor was the size of a dime. I switched out the divertors and it sure seems like the ignition is much better. I can only assume that Atwood had someone grabbed a pilot ignition burner and put it in an electronic ignition water heater. Or perhaps someone at the dealer was troubleshooting a pilot ignition water heater and swapped it out. Perhaps this will help someone else.

New Post
 8/17/2013 9:15 AM
 
Thanks Dan. That certainly is a weird one. Glad you figured it out.

Libby and John and RV the CAT Ford F 150 towing a 2017 Forest River Vibe 277 RLS Click here to see our current location
Previous Previous
 
Next Next
RVAmerica ForumsRVAmerica ForumsBulletin BoardBulletin BoardGeneralGeneralAtwood G6A 8E intermittent Ignition problemAtwood G6A 8E intermittent Ignition problem

Horizon Block
Progressive Insurance